不积跬步无以至千里,不积小流无以成江海

 Administrator     2022-04-29      服务器/设计      2315

服务器上多PHP版本,以及composer 选择PHP版本。

本次遇到的问题:

1.每次都要确认是否使用root用户

2.各种notice报文

解决:

php -v

查看当前服务器默认的PHP版本。

我使用的是宝塔环境。本身有php7.4,新环境需要8.1环境。

rm -f /usr/bin/php

删除默认PHP

ln -sf /www/server/php/81/bin/php /usr/bin/php

创建php的8.1版本的软链接

此时php -v就能看到是默认的8.1环境了。

这个时候需要升级composer

composer selfupdate

然后再执行相对应的依赖就ok了。

==================================

也在在homestead文件的homestead.yaml文件里

- map: movies.v5.fit
      to: /home/vagrant/code/e1a/movies/public
      php: "8.1"

2022年6月23日更新